Author Topic: NetBeans settings problém ....  (Read 5205 times)

kubiaxk

  • Newbie
  • *
  • Posts: 6
    • View Profile
NetBeans settings problém ....
« on: 05.04.2012, 23:07:17 »
Mám problém s týmto tu programom ...

nainštaloval som si to všetko podľa tutorialu ...  http://it4kt.fei.tuke.sk/c/pvjc/installation.html



Nejde mi v tom debugnuť a spustiť ani ten najzákladnejší program aký existuje

Code: [Select]
#include <stdio.h>
 
 int main(void) {
     printf("Hello, world!\n");
     return 0;
 }



hádže mi to toto :









Moje nastavenia:









Keďže v NB musím robiť zadanie dosť ma to vytáča , že mi to  nejde , ... nenapadá vás nejaké riešenie ?   :ropebanana:

Luk1

  • Sr. Member
  • ****
  • Posts: 401
    • View Profile
Re: NetBeans settings problém ....
« Reply #1 on: 05.04.2012, 23:10:56 »
nemas nahodou este subor main s funkciou man v tej zlozke source ? ked kliknes na plus

Za slovensky narod bije mi srdce v hrudi.

kubiaxk

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: NetBeans settings problém ....
« Reply #2 on: 05.04.2012, 23:15:24 »
myslím že v tom to nebude ... presunul som to do source robí to to isté  ....


nejaké iné nápady prečo mi to hádže tie 

.
.
.
.
.
 make[1]: *** [.build-conf] Error 2
make: *** [.build-impl] Error 2


BUILD FAILED (exit value 2, total time: 458ms)
« Last Edit: 05.04.2012, 23:21:56 by kubiaxk »

Luk1

  • Sr. Member
  • ****
  • Posts: 401
    • View Profile
Re: NetBeans settings problém ....
« Reply #3 on: 05.04.2012, 23:36:57 »
mas tam dve main funkcie urcite, a mozes mat v projekte len jednu cize naco si robil newmain.c ked uz tam mas jednu main.c ?
« Last Edit: 05.04.2012, 23:40:21 by Luk1 »

Za slovensky narod bije mi srdce v hrudi.

kubiaxk

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: NetBeans settings problém ....
« Reply #4 on: 05.04.2012, 23:40:20 »
Pozývam ťa na pivo  :buttrock:

Ing. nemtom

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7708
  • lofr dyslektik
    • View Profile
Re: NetBeans settings problém ....
« Reply #5 on: 05.04.2012, 23:48:06 »
ved uz v prvom screenshote mas 'multiple definition of _main' a podtym kde je definovane prvykrat. tie vypisy tam niesu pre srandu, staci ich citat
brix will be shat

kubiaxk

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: NetBeans settings problém ....
« Reply #6 on: 06.04.2012, 03:40:17 »
Na pc sa mi to nejak podarilo rozbehat, ale na nb som nainstalloval presne ako na pc ... a robi mi to zase takuto chybu pri programe Hello world

screen:



Error
Code: [Select]
"/usr/bin/make" -f nbproject/Makefile-Debug.mk QMAKE= SUBPROJECTS= .build-conf
make[1]: Entering directory `/cygdrive/c/Users/kubiaxk/Documents/NetBeansProjects/CppApplication_2'
"/usr/bin/make"  -f nbproject/Makefile-Debug.mk dist/Debug/Cygwin-Windows/cppapplication_2.exe
make[2]: Entering directory `/cygdrive/c/Users/kubiaxk/Documents/NetBeansProjects/CppApplication_2'
mkdir -p build/Debug/Cygwin-Windows
rm -f build/Debug/Cygwin-Windows/main.o.d
gcc.exe    -c -g -MMD -MP -MF build/Debug/Cygwin-Windows/main.o.d -o build/Debug/Cygwin-Windows/main.o main.c
nbproject/Makefile-Debug.mk:65: recipe for target `build/Debug/Cygwin-Windows/main.o' failed
make[2]: Leaving directory `/cygdrive/c/Users/kubiaxk/Documents/NetBeansProjects/CppApplication_2'
nbproject/Makefile-Debug.mk:58: recipe for target `.build-conf' failed
make[1]: Leaving directory `/cygdrive/c/Users/kubiaxk/Documents/NetBeansProjects/CppApplication_2'
nbproject/Makefile-impl.mk:39: recipe for target `.build-impl' failed
make[2]: gcc.exe: Command not found
make[2]: *** [build/Debug/Cygwin-Windows/main.o] Error 127
make[1]: *** [.build-conf] Error 2
make: *** [.build-impl] Error 2


BUILD FAILED (exit value 2, total time: 2s)

 


+ wtf je toto a ma to asi suvis s tym ze mi to zase nejde debugnut co ?












sorry fakt som v tom lama a nevyznam sa v tych vypisoch .... tak to davam sem




lilu

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: NetBeans settings problém ....
« Reply #7 on: 06.04.2012, 03:59:39 »
Rád by som ti poradil Kubo, ale neviem čo ti tam môže nejisť..
Ja to mám na w7 a normalne mi to ide...možno si fakt dačo preskočil pri inštalácii, inak neviem..
Treba pekne všetko aj tie kompilery zaškrtnúť pri inštalácii a potom to nastaviť...
Pri vytváraní projektu tiež treba zvoliť správne C aplication...nastaviť external terminal na každý projekt...

lilu

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: NetBeans settings problém ....
« Reply #8 on: 06.04.2012, 04:03:13 »
ozaj, či si nezabudol pri inštalácii zaškrtnúť ten make compiler....

Luk1

  • Sr. Member
  • ****
  • Posts: 401
    • View Profile
Re: NetBeans settings problém ....
« Reply #9 on: 06.04.2012, 04:09:21 »
klikni pravym na projekt daj propertie a posli screen a  posli screen zalozky build

Za slovensky narod bije mi srdce v hrudi.

kubiaxk

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: NetBeans settings problém ....
« Reply #10 on: 06.04.2012, 04:23:16 »




tuto na netbooku to neviem rozbehat :D  este ze na PC mi to ide   :buttrock:


#lilu ne ne pri inštalácií som nezabudol na nič ...
« Last Edit: 06.04.2012, 04:34:21 by kubiaxk »

mirek

  • Sr. Member
  • ****
  • Posts: 448
  • darkman ZX 128k
    • View Profile
    • domovská stránka
Re: NetBeans settings problém ....
« Reply #11 on: 10.04.2012, 15:29:23 »
pravdepodobne mas ryzu v nastaveni nastrojov pre jazyk C. otazkou totiz je, ako je tato sada pomenovana v netbeanse a aka je zvolena v projekte (podla tvojho posledneho screenu je to cast Tool Collection s hodnotou Default: Cygwin). skontroluj si este v hlavnom okne cez menu Tools->Options, v dialogovom okne klikaj na C/C++ a pozri sa, ktora z tvojej sady je naozaj aktivna (ma rozpoznane/nainstalovane vsetky nastroje, ako sa vola, ...) no a prave tuto sadu potrebujes vybrat/zvolit aj pre tvoj projekt.
So say we all!

Rajo

  • Sr. Member
  • ****
  • Posts: 346
    • View Profile
Re: NetBeans settings problém ....
« Reply #12 on: 10.04.2012, 15:48:21 »
keď sa tu už riešia problémy s NB, neviem prečo ale "podčiarkuje" mi printf a scanf funkciu...akoby ich nevedel nájsť, pričom všetko skompiluje úspešne, program sa spusti, žiadny error, warningy... includy samozrejme, že mám, inak by mi to neskompilovalo...any idea ? Robí mi to len pri "printf" a "scanf"... pri červenom výkričníku mi píše: "Unable to resolve identifier printf(scanf) " ...

Rimbaud

  • Hero Member
  • *****
  • Posts: 556
    • View Profile
Re: NetBeans settings problém ....
« Reply #13 on: 10.04.2012, 18:57:57 »
keď sa tu už riešia problémy s NB, neviem prečo ale "podčiarkuje" mi printf a scanf funkciu...akoby ich nevedel nájsť, pričom všetko skompiluje úspešne, program sa spusti, žiadny error, warningy... includy samozrejme, že mám, inak by mi to neskompilovalo...any idea ? Robí mi to len pri "printf" a "scanf"... pri červenom výkričníku mi píše: "Unable to resolve identifier printf(scanf) " ...

Máš tam červený výkričník a skompiluje ti to ? :O
Zatiaľ som si žil s mylnou predstavou že len žlté výkričníky (warningy) ti dovolí kompilovať :D
« Last Edit: 10.04.2012, 19:06:51 by Informatik »
Meat is Murder.

Rajo

  • Sr. Member
  • ****
  • Posts: 346
    • View Profile
Re: NetBeans settings problém ....
« Reply #14 on: 10.04.2012, 22:03:41 »
keď sa tu už riešia problémy s NB, neviem prečo ale "podčiarkuje" mi printf a scanf funkciu...akoby ich nevedel nájsť, pričom všetko skompiluje úspešne, program sa spusti, žiadny error, warningy... includy samozrejme, že mám, inak by mi to neskompilovalo...any idea ? Robí mi to len pri "printf" a "scanf"... pri červenom výkričníku mi píše: "Unable to resolve identifier printf(scanf) " ...

Máš tam červený výkričník a skompiluje ti to ? :O
Zatiaľ som si žil s mylnou predstavou že len žlté výkričníky (warningy) ti dovolí kompilovať :D

ano, pretože v stdio je printf a aj scanf...akoby to NB nevedel zistiť, že to má knižnica stdio..abo ja neznám čo :D

kubiaxk

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: NetBeans settings problém ....
« Reply #15 on: 12.04.2012, 03:31:37 »
Problem sloved .... preinštaloval som OEM W7 starter za pančovaný Ultimate x64  a nainštaloval znova a všetko už ide jak ma  .... takže W7 s = MEGAULTRABULŠIT

ApokalypS

  • Hero Member
  • *****
  • Posts: 5801
  • apokalyps(a) sa mení..
    • View Profile
    • projekt k mojej diplomovke..
Re: NetBeans settings problém ....
« Reply #16 on: 12.04.2012, 17:16:49 »
windoze vseobecne, no ale to patri inam..
80% mozgu človeka tvorí kvapalina, v mojom prípade brzdová..

CHCEM S5 :zuzka: STARY IS :zuzka: !!!!
http://www.tu-ke.com/forum/o-nicom/otvoreny-list-vedeniu-firmy-dupress-(dodavatel-mais)/